Outlook 2016 for few exchange online mailboxes were showing status of ‘need password’ and outlook wasn’t connecting.

  • Problem Description
    • Users were getting ‘need password’ status in Outlook 2016. Upon clicking need password, users were not getting authenticated and get a Window saying “You’ll need internet for this. We couldn’t connect to one of the services we needed to sign you in. Please check your connection and try again.

                  Need Password

  • Outlook will not connect and will get stuck on ‘Need Password’ and show below error. Sometime a reboot or new profile may work but problem would occur again.

Error

  • Cause:
    • We collected fiddler unencrypted logs, verified with our Identity Provider and all clues were pointing to outlook. We saw some 401’s in fiddler trace and it’s reason was unidentified.
    • Checked with Microsoft and they gave article that this is a known issue for Office 2016 build 16.0.7967 or a later version on Windows 10. This is happening because of the introduction of WAM and it is blocking non-secure endpoints (non-HTTPS) traffic in authentication workflows.
      • Ref : https://support.microsoft.com/en-us/help/4025962/can-t-sign-in-after-update-to-office-2016-build-16-0-7967-on-windows-1
  • Fix
    • Adding registry key on local users profile fixed the issue. we have to keep an eye on below article for any further update on permanent fix.[HKEY_CURRENT_USERSoftwareMicrosoftOffice16.0CommonIdentity] “DisableADALatopWAMOverride”=dword:00000001
    • Ref : https://support.microsoft.com/en-us/help/4025962/can-t-sign-in-after-update-to-office-2016-build-16-0-7967-on-windows-1

 

Advertisements